WP tutorial

WP error-No working transports found

The WordPress site was mostly working without a problem except in a dashboard section of the site, where it was having some issues with updating or installing. When I tried to install theme,it gave me error “Installation failed: Download failed. No working transports found”.agroexpert_az No working transports

Fortunately, i fixed the problem with following solution.

It turns out, this error message occurs when there are missing extensions on a development server, so the WordPress is unable to make external HTTP requests.

The solution is pretty simple. The missing extensions that make those HTTP requests possible are already installed with Wamp Server, By default,they are just disabled. To enable them, we need to edit the php.ini configuration file.

Editing php.ini file

The php.ini file contains a list of many extensions with some of them disabled by default. The only one I had to enable was the openssl extension.

Here are the steps to enable that extension:

  1. Start Wamp Server.
  2. click on Wamp Server Icon and move to PHP->php.ini option.
  3. double click on php.ini. so, it will open php.ini file in your default Text Editor.
  4. search for php_openssl.dll in php.ini file. ->You Will see that the extension is commented out: ;extension=php_openssl.dll
  5. Uncomment that line by removing semi colon(;)
  6. save the changes.
  7. Restart Wamp Server.

That’s it We Are Done!

Note: But in my case, i just deleted php.ini file and the problem solved ))

LEAVE A RESPONSE

Your email address will not be published. Required fields are marked *

Əvvəlki həyatımda developer idim. :)
error: Content is protected !!